Problem with Housenumber-Range in Street field

deals with geocoding and reverse geocoding

Problem with Housenumber-Range in Street field

Postby Howard » Wed Oct 12, 2016 12:13 pm

Hi,

we just encountered an issue with an address and I was trying out different settings in the xLocateServer but I wasn't able to get better results.

Code: Select all
country="D"
postCode="12105 "
city="Berlin"
street="Ringstr. 103/106"


This will return hits with completely different postcodes, but with Streets like "Straße 106" and "Straße 103".

If I remove the "/" from the street and replace it with a space, it works fine. "-" also does not work.

It's unfortunate that I cannot use put the house number in the appropriate field, since that would fix everything. :?

Any suggestings?

Regards,

Sven Howard
Howard
 
Posts: 5
Joined: Thu Aug 04, 2016 9:22 am

Re: Problem with Housenumber-Range in Street field

Postby Bernd Welter » Fri Oct 14, 2016 10:24 am

Hello Sven,
how about this approach? I changed some values in the native profile:
<HNr.RangeSeparators Value="" Type="string"/>
<Intersections.Enable Value="0" Type="bool"/>
<Intersections.Separators Value="\¤ at ¤ @ ¤ ecke ¤" Type="string"/>

wessendorf.PNG
Result after the proposal has been applied

Looks good...

Best regards Bernd
Bernd Welter
Manager Technical Consulting & Requirement Engineering
Senior Technical Consultant Developer Components
PTV GROUP - Germany

https://www.youtube.com/channel/UCgkUli9yGf0gwTDdxbMZ-Kg
User avatar
Bernd Welter
Site Admin
 
Posts: 870
Joined: Mon Apr 14, 2014 10:28 am

Re: Problem with Housenumber-Range in Street field

Postby Howard » Tue Oct 18, 2016 10:16 am

That does the trick!

Thanks you very much. :)

Sven Howard
Sven Howard
Wessendorf Software & Consulting GmbH
http://www.wsc.biz
Howard
 
Posts: 5
Joined: Thu Aug 04, 2016 9:22 am


Return to PTV xLocateServer