Error 2910 / dataCompatibilityVersion

Deals with generic topics such as logging, framework and so on. If you are not sure where to place your topic just put it here.

Error 2910 / dataCompatibilityVersion

Postby Bernd Welter » Tue Oct 16, 2018 8:27 am

Hello together,

we currently get asked for the meaning of the following error message and I therefore want to write a short comment about it:
Appearance in the logfiles:
CODE: ERROR (2910)
The profile truckfast.xml does not match the map, its dataCompatibilityVersion is 1, but the map requires version 2.

On client side:
xml code
<ns6:stackElement className="com.ptvag.xserver.xroute.XRouteException" 
errorKey="2910"
message="The profile truckfast.xml does not match the map,
its dataCompatibilityVersion is 1, but the map requires version 2.">


The reason for this error message is a feature we implemented in 1.26.0.0 (not a bug, by the way!):
Improvement: Added new attribute 'dataCompatibilityVersion' to the stored profiles in order to check consistency and validity with new PTV map data version. Please ensure that your profiles and map data have the same version as otherwise the PTV xDima won't start (see 'Technical Concepts - About Profiles - Profile & Map Versions').


So there's an optional parameter in the XML which can be used as snippet or on server side:
xml code
<?xml version="1.0" encoding="UTF-8"?>
<Profile dataCompatibilityVersion="2">

Within our latest maps we started to give them a data version numbering, e.g.
Map AreaCompatibility Version
PTV Europe City Map Premium <= 2018.21
PTV Europe City Map Premium 2019.12
PTV North America City Map <= 20171
PTV North America City Map 2018.12
......

So the 1st map of V2 in the European region is 2019. Other maps such as North America have been upgraded to v2 with the 2018 data.

http://xserver.ptvgroup.com/fileadmin/f ... s%7C_____1

So the error message occurs if the effective profile's dataCompatibilityVersion doesn't match the servers map dataCompatibilityVersion.

As a server itself isn't assembled in the context of a specific map region we have now two different sets of default profiles. Current servers are shipped with profiles in version 1 and we can provide profiles in versio 2 on demand.

So what does this mean for you if the error message appears?
  • Check whether your server profiles require an update, e.g. because you updated from PTV Europe City Premium 2018.2 to 2019.1
  • Check whether your application sends an XML profile snippet (overrides server profile value) that refers to an unmatching version.
  • If you don't know how to approach this: get in touch with PTVs technical team to get assistance.

Best regards,
Bernd
Bernd Welter
Senior Technical Consultant Developer Components
PTV GROUP - Germany

Bernd at Youtube
User avatar
Bernd Welter
Site Admin
 
Posts: 1335
Joined: Mon Apr 14, 2014 10:28 am

Return to Generic questions

cron