Problem Viewing Xmap / Xlocate

Within this forum we want to offer discussions all around our .NET based Map control including all .Net-language specific questions concerning calls of the xServer-API. Attention: xServer-relevant concepts can be found in further forums such as xRoute or xTour.

Problem Viewing Xmap / Xlocate

Postby dstest » Mon May 13, 2019 1:32 pm

Hi,
we are using .net Map-Control and have very often on Aplication start the problem that the control remeins grey. It seems that it does not initialize

Version of Ptv.XServer.Controls.Map is 1.6.0.16794

other xserver controls like xlocate also init with erros:

- $exception {"Es war kein an https://api-eu.cloud.ptvgroup.com/xlocate/ws/XLocate lauschender Endpunkt vorhanden, der die Nachricht annehmen konnte. Dies wird häufig durch eine fehlerhafte Adresse oder SOAP-Aktion verursacht. Weitere Details finden Sie unter ""InnerException"", sofern vorhanden."} System.ServiceModel.EndpointNotFoundException
- InnerException {"Der Remotename konnte nicht aufgelöst werden: 'api-eu.cloud.ptvgroup.com'"} System.Exception {System.Net.WebException}

Can you help me with that?
BR Frank
dstest
 
Posts: 5
Joined: Mon Aug 06, 2018 11:11 am

Re: Problem Viewing Xmap / Xlocate

Postby Bernd Welter » Mon May 13, 2019 2:07 pm

Hello Frank,

I forwarded this info to our DEV OPS because it is related to our production environment.

:!: Attention: topics which refer to PROD should always be handeled via support (prio A ticket!) and not on this discussion platform (as the forum doesn't grant any response times). Use the forum for strategic discussions such as
  • Is there a method that allows me to ...?
  • ...a parameter...
  • How to approach ....?
Best regards,
Bernd
Bernd Welter
Senior Technical Consultant Developer Components
PTV GROUP - Germany

Bernd at Youtube
User avatar
Bernd Welter
Site Admin
 
Posts: 1335
Joined: Mon Apr 14, 2014 10:28 am

Re: Problem Viewing Xmap / Xlocate

Postby Marco » Tue May 14, 2019 8:40 am

Hello Frank,

the mentioned System.ServiceModel.EndpointNotFoundException happens, if a domain name could not be resolved. If this happens often, it leads to assume a network problem.

To avoid a necessary application restart, if the map control stay grey, I recommend using a strict layer initialization. Please have a look to this code sample.

https://github.com/ptv-logistics/xserver.net-samples/blob/master/CustomInit/Window1.xaml.cs#L52-L75
Marco Schmitt
Software Developer
PTV GERMANY
User avatar
Marco
 
Posts: 19
Joined: Wed Feb 24, 2016 12:09 pm
Location: Karlsruhe, Germany


Return to PTV xServer.NET (Admin=OH)

cron